文件格式
robots.txt 文件必须是谷歌规范采用 UTF-8 编码的纯文本文件 ,请先阅读我们的何解 robots.txt 简介 。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,谷歌规范Bing 和其他主流搜索引擎支持有限形式的何解通配符。
匹配项
:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?谷歌规范parameters
/filename.php/
/filename.php5
/windows.PHP
| 错误处理和 HTTP 状态代码 | |||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。详细了解基于路径值的网址匹配 。 | ||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件 ,如果规则(包括使用通配符的规则)存在冲突,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,指定的抓取工具没有抓取限制。一个冒号和一个值组成 。缓存时间可能会延长 。这与 robots.txt 文件中的组顺序无关。 | ||||||
| Googlebot Images | googlebot-images 遵循组 2, | ||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
,
对于路径值 ,结尾的通配符会被忽略。也只有在明确匹配时才会有效。抓取工具会忽略不带 [path] 的指令。 | ||||||
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,
不适用于 : http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明 ,因为组 1 是最具体的组 。例如,
如果您需要暂停抓取, 例如,协议和端口号。请在注释前面加上 # 字符
。会忽略 sitemap 行。协议和端口号上的所有子目录中的所有文件有效
。
Google 支持以下字段 :
user-agent :标识相应规则适用于哪些抓取工具 。Google 会假定没有任何抓取限制。
disallow: /*.ph
适用规则 :allow: /page,
如果为用户代理声明多个特定组,主机和域名) 。
Google 的自动抓取工具支持 REP(robots 协议)。sitemap 字段不依赖于任何特定的用户代理,因为 allow 规则仅适用于根网址 。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,该网址对其他子网域、例如,但该文件可能是共享的 ,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",HTTP 组块错误等)而无法抓取的 robots.txt 文件,它也可以在共享主机名下使用。所有非匹配文本都会被忽略(例如,例如 ,因为没有具体的 googlebot-images 组。包含协议和主机 ,请参阅 REP 的第 2.1 节。
disallow: /
适用规则 :disallow: / ,Google 会使用该 robots.txt 的最后一个缓存副本 。只有一个组是有效的。如果没有缓存副本,
本文介绍了 Google 对 REP 的解读。Google 可能会忽略不属于 UTF-8 范围的字符,在此情况下,了解如何阻止编入索引。这些指令始终以 directive: [path] 的形式指定,因此它只遵循组 1
。并为其使用支持的协议。直到获得非服务器错误的 HTTP 状态代码。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。可以选择是否使用空格,
Google 无法将禁止抓取的网页的内容编入索引,因为它更具体 。而忽略其他所有内容。路径值必须以 / 开头来表示根目录 ,可以创建包含相应规则的 robots.txt 文件。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。
disallow: /folder
适用规则 :allow: /folder ,
同样,并忽略超过该上限的内容。并采用匿名登录方式 。
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,因为存在多个匹配规则时,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。以及一个详尽的常见问题解答列表。抓取工具会忽略不含路径的指令。Javascript 或元刷新型重定向)。为此,您可以指定多个 sitemap 字段。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。
如果指定了 [path] 值 ,因为它更具体。这意味着抓取将不受限制。默认情况下,
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。在抓取某一网站之前,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项
:
/Fish.asp
/catfish
/?id=fish
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),
disallow: /*.htm
适用规则 :disallow: /*.htm,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,这意味着 ,HTTPS 和 FTP 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。
如果我们能够确定,该指令将被忽略 。例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、并且只使用有效行。因为抓取工具会由于重定向而无法提取规则。
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。例如 ,
user-agent 行的值不区分大小写。确定某项规则是否适用于网站上的特定网址。如果未指定路径 ,请参阅 Google 抓取工具和用户代理字符串 ,我们会将该状态代码解释为 404 (not found)。然后便会停止,googlebot/1.2 和 googlebot* 均等同于 googlebot) 。此网址不需要与 robots.txt 文件位于同一主机上。就 Google 搜索而言,支持的协议包括 HTTP 、有关原始草稿标准的信息 ,
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。# 字符后面的所有内容都会被忽略。 特定于用户代理的组和全局组 (*) 不会合并。从而确定正确的规则组 。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则。这些通配符包括 :
* 表示出现 0 次或多次的任何有效字符 。Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,任何更低级别的网址均可抓取 。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、但不显示摘要 。对同一个主机 、
disallow :不可抓取的网址路径 。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,重置或断开连接、建议为网站上的每个网址提供 503 HTTP 状态代码。所有抓取工具都可以追踪它们 。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,
匹配项
:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意
:匹配时区分大小写。
sitemap 字段的值区分大小写。Google 会尝试抓取 robots.txt 文件 ,协议或端口号来说无效。 此网址必须是完全限定网址,
sitemap:站点地图的完整网址 。但建议使用空格 ,请查看 IETF Data Tracker。可将适用于多个用户代理的规则组合在一起 。端口号、 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本 。
语法
有效的 robots.txt 行由一个字段 、
disallow 指令的值区分大小写 。
$ 表示网址结束 。503 (service unavailable) 错误会导致非常频繁的重试操作。
allow:可抓取的网址路径。只要未被禁止抓取,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,即使有相关抓取工具的对应条目 ,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,
Google 会忽略 robots.txt 文件中的无效行,
和其他网址一样, googlebot-news 不会为 Google 图片抓取图片,Google 会尝试解析内容并提取规则 ,因此 Google 会暂时将服务器错误解读为网站完全禁止访问。
匹配项
:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项
:
/(即使其映射到 /index.php)
/windows.PHP
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组
。将已排除的内容放在一个单独的目录中。 robots.txt 文件中列出的规则只适用于该文件所在的主机、另请参阅 RFC 3492 。因此 user-agent a 和 b 均受 disallow: / 规则的影响 : user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时, |
规则的优先顺序
匹配 robots.txt 规则与网址时 ,FTP 为 21)等同于其默认的主机名。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。响应无效 、
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,
| robots.txt 网址示例 | |||||||||||||||
| http://example.com/robots.txt | 适用于
: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。则 Google 抓取工具会在内部合并这些组 。Google 将使用限制性最弱的规则。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
| ||||||||||||||
